Am running MongoDB 2.2 on Ubuntu and if I run:

sudo mongod

I get an error that it can't find /data/db, which is not where the database is. In mongod.conf the database path is specified as the Ubuntu 10gen default /var/lib/mongodb which is where the db is located. Seems like mongod is not finding the conf file. So when I run:

sudo mongod -f /etc/mongodb.conf

The server starts up fine and output is logged to the log file: /var/log/mongodb/mongodb.log. All is happy. I can switch to another shell, log into mongo shell, see the databases and run queries.

So, I cancel out of that and try to run as a service:

> sudo status mongodb
mongodb stop/waiting
> sudo start mongodb
mongodb start/running, process 10468

Looks good so far, but the mongo server did not start. Running another:

> sudo status mongodb
mongodb stop/waiting
> mongo
MongoDB shell version: 2.2.0
connecting to: test
Sat Sep  1 19:07:43 Error: couldn't connect to server 127.0.0.1:27017 src/mongo/shell/mongo.js:91
exception: connect failed

"test" is not the correct database, and nothing appears in the log file.

I am at a loss as to what could be wrong. I checked the upstart scripts and they seem fine. /etc/init/mongodb.conf runs:

mongodb --exec  /usr/bin/mongod -- --config /etc/mongodb.conf

Solution 1

OK, this all comes down to permissions, but let's take it step by step. When you run sudo mongod it does not load a config file at all, it literally starts with the compiled in defaults - port 27017, database path of /data/db etc. - that is why you got the error about not being able to find that folder. The "Ubuntu default" is only used when you point it at the config file (if you start using the service command, this is done for you behind the scenes).

Next you ran it like this:

sudo mongod -f /etc/mongodb.conf

If there weren't problems before, then there will be now - you have run the process, with your normal config (pointing at your usual dbpath and log) as the root user. That means that there are going to now be a number of files in that normal MongoDB folder with the user:group of root:root.

This will cause errors when you try to start it as a normal service again, because the mongodb user (which the service will attempt to run as) will not have permission to access those root:root files, and most notably, it will probably not be able to write to the log file to give you any information.

Therefore, to run it as a normal service, we need to fix those permissions. First, make sure MongoDB is not currently running as root, then:

cd /var/log/mongodb
sudo chown -R mongodb:mongodb .
cd /var/lib/mongodb
sudo chown -R mongodb:mongodb .

That should fix it up (assuming the user:group is mongodb:mongodb), though it's probably best to verify with an ls -al or similar to be sure. Once this is done you should be able to get the service to start successfully again.

Solution 2

First confirm that the mongodb user/group has permission to write to both the data directory and log file:

$ sudo chown -R mongodb:mongodb /var/lib/mongodb/.

$ sudo chown -R mongodb:mongodb /var/log/mongodb.log

Start up MongoDB as a Daemon (background process) using the following command:

$ mongod --fork --dbpath /var/lib/mongodb/ --smallfiles --logpath /var/log/mongodb.log --logappend

To Shut Down MongoDB enter the Mongo CLI, access the admin and issue the shutdown command:

$ ./mongo

> use admin

> db.shutdownServer()

Ref: http://www.mongodb.org/display/DOCS/Starting+and+Stopping+Mongo

Solution 3

I too had the same problem. So I went to cd /var/lib/mongodb/ and deleted the mongod.lock file Then it worked for me.

Solution 4

After checking all permission in the data, journal and log folders as suggested by @nelsonic, my problem was solved by giving permission to lock file in the /tmp folder

sudo chown mongod:mongod mongodb-27017.sock  

I was running it as a AWS Amazon Linux instance. I figured that out by executing as the mongod user as below, and then, researching the error code. It might be useful for other troubleshooting.

sudo -S -u mongod mongod -f /etc/mongod.conf

Solution 5

Just try this command:

sudo chown mongodb /tmp/mongodb-27017.sock

Solution 6

Nothing worked for me, then I've found that it was a permissions problem on /tmp directory:

sudo chmod 1777 /tmp
sudo chown root:root /tmp

Solution 7

None of the above answers worked for me. I finally figured it out by debugging the init script with:

sudo bash -x /etc/init.d/mongodb start

And seeing it was passing the wrong config path to mongod. I simply changed the line in /etc/init.d/mongodb from "CONF=/etc/mongodb.conf" to "CONF=/etc/mongod.conf". Version 2 uses the former, and installing version 3 added /etc/mongod.conf with the new format but apparently did not update the init script.

UPDATE: I now have a much stranger problem where the init script works, but only if I run it with "sudo bash -x /etc/init.d/mongodb start" and not with "sudo service mongodb start". Same thing for stop.

Solution 8

My mongodb was starting when launched from the command line as the mongod user, but not as a service with User=mongod. After an hour checking permissions, definition of the service, sockets... it was SElinux !

In /etc/selinux/config I switched from enforcing to permissive and reboot. It is now ok.

Solution 9

After none of the above answers worked for me, deleting my log file brought Mongo back to life.

Solution 10

These days this error can occur if you've updated mongod and you are running and old database. Mongod will be using the wiredTiger engine by default and you'll have a mmapv1 database

edit the engine setting in /etc/mongod.conf

# engine: wiredTiger
engine: mmapv1

Careful - YAML is whitespace sensitive

journalctl/systemd won't see this problem. Check the mongod log in /var/log/mongodb/mongod.log

I presume you can convert the database with something like the steps outlined here

https://docs.mongodb.com/manual/tutorial/change-standalone-wiredtiger/