I am new to Ubuntu (Linux tbh). I encountered problem with starting MongoDB service. I want to created web app using Ruby on Rails and MongoDB but mongo seems to fail to start.

I followed this MongoDB installation on Ubuntu all of installation went without problems until I got to sudo service mongod start

mongod.log

2016-01-01T10:58:15.545+0000 I CONTROL  ***** SERVER RESTARTED *****
2016-01-01T10:58:15.548+0000 I CONTROL  [initandlisten] MongoDB starting : pid=3868 port=27017 dbpath=/var/lib/mongodb 64-bit host=damian-CX61-0NC-CX61-0ND-CX61-0NF-CX61-0NE
2016-01-01T10:58:15.548+0000 I CONTROL  [initandlisten] db version v3.0.8
2016-01-01T10:58:15.548+0000 I CONTROL  [initandlisten] git version: 83d8cc25e00e42856924d84e220fbe4a839e605d
2016-01-01T10:58:15.548+0000 I CONTROL  [initandlisten] build info: Linux ip-10-187-89-126 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 BOOST_LIB_VERSION=1_49
2016-01-01T10:58:15.548+0000 I CONTROL  [initandlisten] allocator: tcmalloc
2016-01-01T10:58:15.548+0000 I CONTROL  [initandlisten] options: { config: "/etc/mongod.conf", net: { bindIp: "127.0.0.1", port: 27017 }, storage: { dbPath: "/var/lib/mongodb", journal: { enabled: true } }, systemLog: { destination: "file", logAppend: true, path: "/var/log/mongodb/mongod.log" } }
2016-01-01T10:58:15.567+0000 E NETWORK  [initandlisten] Failed to unlink socket file /tmp/mongodb-27017.sock errno:1 Operation not permitted
2016-01-01T10:58:15.567+0000 I -        [initandlisten] Fatal Assertion 28578
2016-01-01T10:58:15.567+0000 I -        [initandlisten] 

***aborting after fassert() failure

So what I am doing wrong or its different issue?

Solution 1

SOLUTION by kometen

Does the file /tmp/mongodb-27017.sock exist? If so try to delete it, ie. 'sudo rm /tmp/mongodb-27017.sock'.

Solution 2

The problem can also be due to mongodb using up all the disk space. That was the case for me. You can install ncdu with this command: sudo apt install ncdu

This will help you in looking at the disk usage. Use the command: ncdu -x /

Remove the unwanted dbs from /var/lib/mongodb/

Solution 3

sudo mongod

(suggested by @João Bortolosso)

after (suggested by @fresz):

sudo rm /tmp/mongodb-27017.sock

worked on mac!

Solution 4

If you use Ubuntu, try:

sudo mongod

Solution 5

For me, it was because of the bad data inside the folder: /data/db

Solution that worked for me: Remove all the files inside '/data/db'

Solution 6

mongo --shell

It worked for me on ubuntu

Solution 7

We was getting the same message in Production and service was not restarted

{"t":{"$date":"2021-08-18T15:18:27.834+00:00"},"s":"F",  "c":"-",        "id":23092,   "ctx":"initandlisten","msg":"\n\n***aborting after fassert() failure\n\n"}

So I ran this command (Giving the permission to mongodb user)

sudo chown mongodb:mongodb mongodb-27017.sock

And started the service

sudo systemctl start mongod

Now mongo is up and running. ;)

Credit Goes to our StackOverflow Contributor Rajith K

He gave the answer on 'Failed to unlink socket file" error in MongoDB 3.0

Solution 8

You need to delete MongoDB temp file

sudo rm /tmp/mongodb-27017.sock

for any one getting this error after every restart, u need to stop mongod.service on startup

sudo systemctl disable mongod.service

the name mongod.service may change later, so just write mongo and press tab for autocompletion