I have tried all methods mentioned on the internet but there is no use. I am trying to install misaka by writing pip install misaka it keeps complaining by showing the same message. I have downloaded and installed MS build tool 2015 and 2017, Restarted my laptop. Whatever I did, couldn't figure out why it complains. Python version 3.6.4 Windows 10

Solution 1

To solve any of the following errors:

  • "Failed building wheel for misaka"
  • "Failed to build misaka"
  • "Microsoft Visual C++ 14.0 is required"
  • "Unable to find vcvarsall.bat"

The solution is:

  1. Go to: https://www.visualstudio.com/downloads/#build-tools-for-visual-studio-2017

  2. Select the free download under Visual Studio Community 2017

    • This will download the installer.
    • Run the installer
  3. Now the most important step is to select what you need under the workload tab:

    • Under Windows there are 3 choices. ONLY check "Desktop development with C++"
    • Under Web & Cloud there are 7 choices. ONLY check Python development (I believe this is optional but I still did it).
  4. Now go to your cmd and install the package:

    pip3 install misaka
    

Note that if you already installed Visual Studio then when you run the installer, you can modify it (click the modify button under Visual Studio Community 2017) and do steps 3 and 4.

Solution 2

Using the https://visualstudio.microsoft.com/visual-cpp-build-tools/ installer only and selecting only four specific components helped solve the error.

Solution 3

I was getting the same error when trying to install biopython with Python 3.7 on Windows 10.

Installing just the Build Tools (instead of the full Community Edition as suggested in the other answer), with the options "C++/CLI support" and "VC++ 2015.3 v14.00 (v140) toolset for desktop" checked in addition to the defaults, solved the problem.

Solution 4

I did a variation of @Jason246 answer, to keep up with changes to the website.

I was having a problem with a pip install spacy that gave the same problem in the title.

This is running on a Windows 10 machine.

First, I went directly to https://visualstudio.microsoft.com/downloads/#build-tools-for-visual-studio-2017 .

Then I clicked the Download button. The download was 71 Mb at the time. Then pressed the install button when the download ran. The install took a long time as it had to create a Windows restore point.

Then I started the installer and checked the following:

I selected

  • Windows 10 SDK
  • C++ CMake tools for Windows

(and the VS 2019 C++ came along for the ride).

I ran

pip install spacy

and am no longer getting the error for C++ 14.0.