I'm relatively new to MongoDB and am trying to install MongoDB on my Mac with Homebrew, but I'm getting the following error:

Error: No available formula with the name "mongodb" 
==> Searching for a previously deleted formula (in the last 
month)...
Warning: homebrew/core is shallow clone. To get complete history 
run:
  git -C "$(brew --repo homebrew/core)" fetch --unshallow

Error: No previously deleted formula found.
==> Searching for similarly named formulae...
Error: No similarly named formulae found.
==> Searching taps...
==> Searching taps on GitHub...
Error: No formulae found in taps.

I ran brew update Then brew install mongodb

Solution 1

Formula mongodb has been removed from homebrew-core. Check pr-43770 from homebrew-core

To our users: if you came here because mongodb stopped working for you, we have removed it from the Homebrew core formulas since it was migrated to a non open-source license.

Fortunately, the team of mongodb is maintaining a custom Homebrew tap. You can uninstall the old mongodb and reinstall the new one from the new tap.

# If you still have the old mongodb installed from homebrew-core
brew services stop mongodb
brew uninstall homebrew/core/mongodb

# Use the migrated distribution from custom tap
brew tap mongodb/brew
brew install mongodb-community
brew services start mongodb-community

Check mongodb/homebrew-brew for more info.

Solution 2

With regards to macOS Big Sur and Homebrew the mongodb documentation states: https://docs.mongodb.com/manual/tutorial/install-mongodb-on-os-x/

You should install MongoDB 4.4 Community Edition which supports macOS 10.13 or later, Therefor these steps will be helpful.

SOLUTION 1: If you have previously installed an older version of the formula, you may encounter a ChecksumMismatchError to fix that:

Remove the downloaded .tgz archive.

brew untap mongodb/brew && brew tap mongodb/brew

Retap the formula.

  brew install [email protected]4.4 

SOLUTION 2: If you haven't installed any version of the formula.

1, Install the Xcode command-line tools and the Homebrew from https://brew.sh/#install

xcode-select --install

2, Tap the MongoDB Homebrew Tap:

brew tap mongodb/brew

3, Verify installation prerequisites in the macOS Terminal:

brew tap | grep mongodb

4, install MongoDB

brew install [email protected]4.4

Note: The installation includes:

The mongod server,

The mongos sharded cluster query router,

 The mongo shell

refer to this screenshot:

Finally to run MongoDB (i.e. the mongod process) as a macOS service, issue the following:

brew services start [email protected]4.4

screenshot:

Solution 3

first install mongodb

brew tap mongodb/brew

Secondly install using this command. mangodb successfully installed

brew install [email protected]4.0 

You will get the output

==> CaveatsTo have launchd start mongodb/brew/mongodb-community now and restart at login:
  brew services start mongodb/brew/mongodb-community
Or, if you don't want/need a background service you can just run:
  mongod --config /usr/local/etc/mongod.conf
==> Summary
  /usr/local/Cellar/mongodb-community/4.2.2: 21 files, 274.5MB, built in 2 minutes 46 seconds
brew services start mongodb/brew/mongodb-community
==> Successfully started `mongodb-community` (label: homebrew.mxcl.mongodb-commu

Solution 4

Try this code in your terminal:

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)" 

And then:

brew tap mongodb/brew  

Finally:

brew install [email protected]4.0

Solution 5

~ % brew services run mongodb-community
/usr/local/opt/mongodb-community/homebrew.mxcl.mongodb-community.plist: service already loaded

Error: Failure while executing
/bin/launchctl bootstrap gui/501 /usr/local/opt/mongodb-community/homebrew.mxcl.mongodb-community.plist
exited with 17.

Solution 6

In MacOs Catalina doesn't work properly for me.

After the installation (https://zellwk.com/blog/install-mongodb/) i had to add permission to "/tmp/mongodb-27017.sock"

sudo chown -R `id -un` /tmp/mongodb-27017.sock

and the command "mongod" seems to ignore the config file (mongod.conf) in "/usr/local/etc" so i have to always launch it with the dbpath argument

mongod --dbpath /usr/local/var/mongodb

even if the same path is specified in the config file.

Also using "mongod" with configuration file doesn't work for me

mongod -f /usr/local/etc/mongod.conf

or

mongod --config /usr/local/etc/mongod.conf

I solved all these issues starting the mongodb via brew services. That worked well without issues and takes the parameters from the right configuration file.

brew services run mongodb-community