Am trying to add google-play-service library in my project using import(For Google map). After adding the path am getting red X next to this reference and the reference is not adding . Know how to resolve this ?

Solution 1

The red X means its a broken link path.

http://developer.android.com/google/play-services/setup.html

Copy the google-play services_lib library project to your workspace (folder where your android map project is). The library project can be found under the following path.

     <android-sdk-folder>/extras/google/google_play_services/libproject/google-play-services_lib library project .

Import the library project to your eclipse

Click File > Import, select Android > Existing Android Code into Workspace, and browse the workspace import the library project. You can check if it is library project. Right click on the library project. Goto properties. Click Android on the left panel. You will see Is Library checked.

Right click on your android project. Goto properties. Choose Android on the left panel. Click on Add and browse the library project. Select the same. Click ok and apply

Solution 2

Eclipse does weird things when importing an existing project (google-play-services-lib), especially if you try to import and then allow the project to be automatically 'copied' to your workspace. I had the same issue and here is how I fixed it:

  • Close Eclipse

  • Erase all google-play-services projects from your workspace

  • Manually copy the google-play-services-lib folder (....sdk\extras\google\google_play_services\libproject\google-play-services_lib) into your workspace

  • Open Eclipse

  • Add a new project, choosing 'Existing Android Project', then navigate to your workspace and add the newly copied google-play-services-lib project

  • Finally, add the google-play-services-lib to your project as a library (just like you normally would)

Hope this helps! :)

Solution 3

Though it's over a year for this question but never the less thought of putting it down here. Might help some one facing a similar issue.

While doing a File -> Import one probably might have selected the folder,

C:\adt-bundle-windows-x86-20130729\sdk\extras\google\google_play_services\ 

instead of

C:\adt-bundle-windows-x86-20130729\sdk\extras\google\google_play_services\libproject\google-play-services_lib

Quite strange as Eclipse did not correctly copy the google-play-services_lib project in my workspace, but this caused a cross mark to appear in my Project Properties.

Solution 4

got a perfect solution for your question. this problem is due to improper referencing of library projects. You need follow these step.

  1. create a new project
  2. copy all the java files from src of your previous project in which you are getting error to the new project you have created just now.
  3. Also copy layouts xml files.
  4. now import play services you will not get this error.

Solution 5

I was also getting same problem.

I copied google library folder into work space and import now it's working fine.

Solution 6

Try to place the Google-play-service library with in your same working Directory by coping the files from Click File > Import, select Android > Existing Android Code into Work space, and browse the work space import the library project.

Solution 7

This is common issue Youur google-play-service-lib project and your android project should be inside the same folder For example if your Android Appplication name is MyMap is in D:/workspace t hen your play service lib project should be in the same directory D:/workspace

Solution 8

Close Eclipse. Delete

.metadata

and

.recommaditions

folders from your workplace. Import your projects back.

Solution 9

You add Project in to your workspace. Start Eclipse and import project one option is ther copy to workspace do it. After that add google play services it also copy in to your work space and add it your library hope so its working.