when i setup mongodb in my ubuntu , i try : ./mongo it show this error :

 couldn't connect to server shell/mongo.js

so what can i do ,


Solution 1

  • Manually remove the lockfile: sudo rm /var/lib/mongodb/mongod.lock
  • Run the repair script: sudo -u mongodb mongod -f /etc/mongodb.conf --repair

Please note the following:

  • You must run this command as the mongodb user. If you run it as root, then root will own files in /var/lib/mongodb/ that are necessary to run the mongodb daemon and therefore when the daemon trys to run later as the mongodb user, it won't have permissions to start. In that case you'll get this error: Unable to create / open lock file for lockfilepath: /var/lib/mongodb/mongod.lock errno:13 Permission denied, terminating.
  • On Ubuntu, you must specify the configuration file /etc/mongodb.conf using the -f flag. Otherwise it will look for the data files in the wrong place and you will see the following error: dbpath (/data/db/) does not exist, terminating.

Solution 2

sudo rm /var/lib/mongodb/mongod.lock   
sudo -u mongodb mongod -f /etc/mongodb.conf --repair 
sudo service mongodb start

Here is all, sometimes, it takes a little while to start mongo after performing these operations.

Solution 3

Trying running $mongod

If you get en error such as

MongoDB shell version: 2.0.5
connecting to: test
Fri Jun  1 11:20:33 Error: couldn't connect to server shell/mongo.js:84
exception: connect failed

hisham-agil:~ hisham$ mongod
mongod --help for help and startup options
Fri Jun  1 11:24:47 [initandlisten] MongoDB starting : pid=53452 port=27017 dbpath=/data/db/ 64-bit host=hisham-agil.local
Fri Jun  1 11:24:47 [initandlisten] db version v2.0.5, pdfile version 4.5
Fri Jun  1 11:24:47 [initandlisten] git version: nogitversion
Fri Jun  1 11:24:47 [initandlisten] build info: Darwin gamma.local 11.3.0 Darwin Kernel Version 11.3.0: Thu Jan 12 18:48:32 PST 2012; root:xnu-1699.24.23~1/RELEASE_I386 i386 BOOST_LIB_VERSION=1_49
Fri Jun  1 11:24:47 [initandlisten] options: {}
Fri Jun  1 11:24:47 [initandlisten] exception in initAndListen: 10296 dbpath (/data/db/) does not exist, terminating
Fri Jun  1 11:24:47 dbexit: 
Fri Jun  1 11:24:47 [initandlisten] shutdown: going to close listening sockets...
Fri Jun  1 11:24:47 [initandlisten] shutdown: going to flush diaglog...
Fri Jun  1 11:24:47 [initandlisten] shutdown: going to close sockets...
Fri Jun  1 11:24:47 [initandlisten] shutdown: waiting for fs preallocator...
Fri Jun  1 11:24:47 [initandlisten] shutdown: lock for final commit...
Fri Jun  1 11:24:47 [initandlisten] shutdown: final commit...
Fri Jun  1 11:24:47 [initandlisten] shutdown: closing all files...
Fri Jun  1 11:24:47 [initandlisten] closeAllFiles() finished
Fri Jun  1 11:24:47 dbexit: really exiting now

Then you've run into a basic startup error that is pretty common.

By default mongod will try to use /data/db for its database files, which in this case, does not exist.

You can't start


until you handle


Try creating those directories and make sure they are writable by the same user that is running the mongod process.

**See similar question-- Getting an error, "Error: couldn't connect to server shell/mongo.js" & when trying to run mongodb on mac osx lion

Solution 4

This is actually not an error... What happens here is that Mongo relies on a daemon in order to run the local database server, so in order to "fire up" the mongo server in your shell, you have to start the mongo service first.

For Fedora Linux (wich is the Distro I use) You have to run these commands:

1 sudo service mongod start
2 mongo

And there you have it! the server is going to run. Now, If you want Mongo service to Start when the system boots then you have to run:

sudo chkconfig --levels 235 mongod on

And that's all! If you do that, now in the shell you just have to type mongo in order to start the server but that's pretty much it, the problem is you have to start the SERVICE first and then the SERVER :)

P.S. The commands I posted might work on other linux distros as well, not just in fedora... In case not maybe you have to tweak some words depending on the distro you're using ;)

Solution 5

I got the same problem when I tried to install mongo. I got Error as,


"Error: couldn't connect to server shell/mongo.js:84"


First install mongod by using:

sudo apt-get install mongodb-server

Then type

mongod --dbpath /mongo/db


sudo rm /var/lib/mongodb/mongod.lock


sudo -u mongodb mongod -f /etc/mongodb.conf  --repair

Thank You

Solution 6

You need to delete the lockfile mongod.lock or /var/lib/mongodb/mongod.lock on ubuntu, then you need to run mongod.exe or service mongodb start on ubuntu first, then run mongo.exe or mongo on ubuntu.

Solution 7

Either your mongod is not running (check using "ps" command) or it is listening on some outside IP address and not on localhost. So first check the process list if 'mongod' is running. If yes, check with "netstat -nap" for the related port.

Of course you can start mongod on the console manually or even look into the mongod logfile (if there is one configured...depending on how you installed mongod).

Solution 8

First you have to make sure that all the files and directories in your /var/lib/mongodb/ folder (or whichever folder dbpath points to) belong to the mongodb user and mongodb group.

cd /var/lib/mongodb/
sudo chown mongodb filename.*
sudo chgrp mongodb filename.*
sudo chown -R mongodb directory
sudo chgrp -R mongodb directory

(Replace filename and directory with their respective names)

Then you can remove the lock, repair the database and restart the daemon as other people already mentioned:

sudo rm /var/lib/mongodb/mongod.lock   
sudo -u mongodb mongod -f /etc/mongodb.conf --repair 
sudo service mongodb start

Solution 9

First start your mongo server by

Users-MacBook-Pro:csv1 Admin$ mongod
all output going to: /usr/local/var/log/mongodb/mongo.log

Then open another terminal window and open shell

Users-MacBook-Pro:csv1 Admin$ mongo

Solution 10

Also check that your root partition has enough space to start mongod.

df -h /

You'll see smth like this on mongod launch:

Mon Aug 12 17:02:59.159 [initandlisten] recover : no journal files present, no recovery needed
Mon Aug 12 17:02:59.159 [initandlisten] 
Mon Aug 12 17:02:59.159 [initandlisten] ERROR: Insufficient free space for journal files
Mon Aug 12 17:02:59.159 [initandlisten] Please make at least 3379MB available in /var/lib/mongodb/journal or use --smallfiles
Mon Aug 12 17:02:59.159 [initandlisten] 
Mon Aug 12 17:02:59.159 [initandlisten] exception in initAndListen: 15926 Insufficient free space for journals, terminating
Mon Aug 12 17:02:59.159 dbexit: 
Mon Aug 12 17:02:59.159 [initandlisten] shutdown: going to close listening sockets...

Solution 11

On Ubuntu, try this:

sudo invoke-rc.d mongodb start

Solution 12

It could be combination of $PATH and Permission issue.

Try following steps given below:

Update your $PATH variable to point to your MongoDB bin file. In my case brew install MongoDB to this folder:


In order to update your $PATH variable, do following:

$ sudo vi /etc/paths

Then, press i to insert text in Vi and append the your MongoDB path to the end of the paths file and restart the terminal.


Use Esc : w q to save and exit from Vi editor.

Use echo to display your path variable:

$ echo $PATH

Now try to check the Mongo version, if you get following, then you are on the right track!

$ mongo --version
MongoDB shell version: 2.4.6

Now we need to create the database directory. I used the default /data/db location suggested in MongoDB docs. I also created a log directory to avoid any permission issues while Mongo tries to create any logs. Change ownership and that will do the job.

$ sudo mkdir /data/db
$ sudo mkdir /data/log
$ whoami
$ chown -R username /data

Now, we will create a default config file for MongoDB to be provided for the first time we run mongod command. Now, I will also like to point out that mongod will start a service, which will listen for incoming data connections. This is similar having $service mysqld start executed.Lets go ahead and create the config file. Please keep in mind that I have created very basic config file. However, you can add many other variables to configure MongoDB. This is the first time I am playing with MongoDB, so I just know as much as I read on MongoDB docs!I created mongodb.conf.

$ sudo vi /etc/mongodb.conf

Add following:

fork = true
port = 27017
quiet = true
dbpath = /data/db
logpath = /data/log/mongod.log
logappend = true
journal = true

Please note that the default port for MongoDB server is 27017. Use your own path for dbpath and logpath you created in Step 5. Dont forget to close and save the conf file.

Now we are all set to start our MongoDB service. Open two instances of Terminal.In Terminal 1, type in:

$ sudo mongod -f /etc/mongodb.conf
about to fork child process, waiting until server is ready for connections.
forked process: 3516
all output going to: /data/log/mongod.log
child process started successfully, parent exiting

If you get above message, then know that you have successfully started your Mongod service.

Now, to connect to it, in Terminal 2 type following:

$mongo test
MongoDB shell version: 2.4.6
connecting to: test
Server has startup warnings:
Tue Sep 3 16:55:43.527 [initandlisten]
Tue Sep 3 16:55:43.527 [initandlisten] ** WARNING: soft rlimits too low. Number of files is 256, should be at least 1000

Ignore the warnings, but you are successfully connected to the test database! Cool!

That's all. I applied this solution, when I tried to install copy of MongoDB on my Mac for the first time. See if this help you too.

For detailed post you can go here - http://arcanebytes.com/2013/09/03/mongodb-installation-on-mac-os-x/#comment-1036112094.

I hope it helps!

Cheers, Chinmay

Solution 13

I solved this problem on ubuntu 12.04 by following steps:
1) sudo rm /var/log/mongodb
2) sudo rm /var/lib/mongodb
3) I removed mongo and then installed it again
4) sudo service mongodb restart

and All is Well

Solution 14

For Ubuntu:

Just Open the terminal and enter the below command. You just have to restart your mongoDB.

sudo service mongodb restart