I have recently been trying to install PHP and Apache on my computer. After many hours, they're installed. I have modified the httpd.conf and php.ini files like everyone says. I then created a simple PHP script:

<?php phpinfo(); ?>

But when I try to run it with http://127.0.0.1/phpinfo.php it just shows the source code instead of executing it. I am using Apache 2, PHP 5 and Windows Vista.

EDITED LINES:

PHP.INI:

short_open_tag = On

HTTPD.CONF

LoadModule php5_module "C:/php/php5apache2_2.dll"
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
PHPIniDir "C:/php"

Solution 1

You must enable php! Check the folder mods-enabled in the Apache directory (default: /etc/apache2/) to see if you find a file named php. I don't remember the extension but I think it's .so.

Also check in /var/log/apache2/error.log to see if you have any other errors.

Solution 2

Wow, lots of solutions here! Here's what I did on Ubuntu 16.04:

sudo apt-get install php libapache2-mod-php
sudo a2enmod mpm_prefork && sudo a2enmod php7.0
sudo service apache2 restart

Solution 3

For PHP 7 (May apply to previous versions as well), but I had to do this:

Add this to the bottom of /etc/apache2/apache2.conf

<FilesMatch \.php$>
SetHandler application/x-httpd-php
</FilesMatch>

Run this from the terminal:

sudo a2dismod mpm_event && sudo a2enmod mpm_prefork && sudo a2enmod php7

Then don't forget to restart Apache so it knows you changed stuff:

sudo service apache2 restart

This is a summary from: https://www.atlantic.net/community/howto/try-php7-lamp-ubuntu-14-04/

Solution 4

open the file

/etc/apache2/httpd.conf

and change

#LoadModule php5_module libexec/apache2/libphp5.so

into

LoadModule php5_module libexec/apache2/libphp5.so

So just uncoment the PHP module load in httpd.conf

Solution 5

I found this to solve my related problem. I added it to the relevant <Directory> section:

<IfModule mod_php5.c>
    php_admin_flag engine on
</IfModule>

Solution 6

A different answer that worked for me. Is that, to install [sudo] apt-get install libapache2-mod-php5.X

Solution 7

Apache shows php code instead of executing Issue fixed

1. Opened php5.6 conf or php7.x conf

# following command:

$ sudo vi /etc/apache2/mods-enabled/php5.6.conf

2. Commented following lines

3. Restarted the server

$ sudo service apache2 restart

4 Enjoy :)

Solution 8

Thanks to others on this thread for their suggestions. Following the steps mentioned I found that the apache server was not able to start reporting a syntax error in a load file in /etc/apache2/mods-enabled. Turns out that both php7.0 and php7.1 were enabled.

a2dismod php7.0
systemctl restart apache2

and php is rendered correctly again.

Solution 9

Add following configuration to /etc/apache2/apache2.conf

<FilesMatch "\.php$">
    SetHandler application/x-httpd-php
</FilesMatch>

And restart the apache via sudo service apache2 restart

Solution 10

Alright if you've tried what you've been told above or earlier(which are possible reasons) and it still displays the code instead of executing it then there is one thing which you are doing wrong that hasn't been addressed. The url you used to access your php code; some people try to execute their php code by just dragging the .php file into the web browser. this is wrong practice and could lead to this kind of problem. if you have saved a file as "test.php" in the C://wamp/www folder then you must access this file this way: localhost://test.php. this kind of mistake will arise when you access it this way: localhost://wamp/www/test.php

Hope I helped someone out there. o/ ~Daniel

Solution 11

If you are a ubuntu user, after installing apache must run the following command in fresh installation

sudo apt-get install php5 libapache2-mod-php5 php5-mcrypt

In my case works fine.

Solution 12

Posting what worked for me in case in helps someone down the road, though it is an unusual case.

I had set a handler to force my web host to use a higher version of php than their default. There's was 5.1, but I wanted 5.6 so I had this:

<FilesMatch \.php$>
    SetHandler php56-cgi
</FilesMatch>

in my .htaccess file.

When trying to run my site locally, having that in there caused php code to be output to the browser. Removing it solved the problem.

Solution 13

For PHP7 and Apache2.4, this is all you need to do:

sudo vim /etc/httpd/conf/httpd.conf

Go to the very bottom and insert the following (all by itself):

<FilesMatch "\.*">
SetHandler application/x-httpd-php
</FilesMatch>

Then, restart Apache to load the new configuration:

sudo service httpd restart

Apache will now execute all HTTP/S requests with PHP. If all you have are html, css, and php files, then this will work fine for you. If you have other languages running, then you'll need to tailor the file matching to your situation. I've tested this with phpMyAdmin and it works fine.

None of that other stuff all the people are talking about here was necessary for me. When I put the "AddType Application....." thing in the correct spot, Apache just told me that that module was already loaded and skipped it.

More information can be found here: https://httpd.apache.org/docs/2.4/mod/core.html#filesmatch

My install was done as follows:

sudo yum install -y httpd24 php70 mysql56-server php70-mysqlnd

You should also read this, if you haven't: https://httpd.apache.org/docs/current/howto/htaccess.html#when

Solution 14

You could delete your .htaceess file and let the system creates a new (blank or basic) one. It may be that some lines you added are incorrect statements, or something else inside is causing the problem. You can then add line by line from your old .htaccess file to see what caused the problem.

That worked for me. The lines telling machine not to display php extensions were problem in my case (RewriteCond and RewriteRule). My old .htaccess file worked just fine on a shared server, but this issue appeared when I switched to VPS.

Solution 15

This was happening to me also when running $_POST in MAMP. All of my .ini and httpd files were all set up correctly. If you are doing form handling and you have an html document and posting the info to a php formhandler running $POST, make sure that you are running the html file from localhost via your server, and not just locally.

This was a shortcut I did to run html documents, by just clicking the html file in my directory and launching in my web browser, when in reality to check if php is being processed in your form, you must run your html through your servers. A very simple protocol that I overlooked.

Example:

Wrong: file:///Applications/MAMP/htdocs/form/form.html

Right: http://localhost:your port number/form/form.html

Now the php should be processed once you click your submit button

Solution 16

What worked for me:

In active httpd.conf, find

<IfModule mime_module>
...
</IfModule>

It was missing the following

AddType application/x-httpd-php .php
AddHandler application/x-httpd-php .php

After restarting apache, .php files are correctly parsed.

Solution 17

if the module userdir is enabled and your site is in a userdir (~/public_html) you must check /etc/apache2/mods-enabled/php5.conf. The following part makes it work (on Ubuntu 14.10 utopic):

# Running PHP scripts in user directories is disabled by default
# 
# To re-enable PHP in user directories comment the following lines
# (from <IfModule ...> to </IfModule>.) Do NOT set it to On as it
# prevents .htaccess files from disabling it.

# <IfModule mod_userdir.c>
#     <Directory /home/*/public_html>
#        php_admin_flag engine Off
#    </Directory>
# </IfModule>

Solution 18

none of the above applied or worked for me... PHP7, Apache Httpd 2.2 on CentOS 6

fact is, I installed (all with yum) php BEFORE Apache... you must do the reverse: always install Apache first, then PHP, and then it works... Indeed, you are likely missing libphp7.so and libphp7-zts.so in /etc/httpd/modules/

I was able to recover anyhow without UNinstalling PHP. I did add the magic line in /etc/httpd/conf/httpd.conf: AddType application/x-httpd-php .php And then run: yum install php php-mysql

Solution 19

I tried a number of the solutions above however the fix in our scenario was to install the fpm-module.

We had installed httpd before php which may have had something to do with the issue, but to resolve we installed the following:

yum module install php:7.2

This installed the php-fpm-7.2.11-4.module+el8.1.0+5443+bc1aeb77.x86_64.rpm module which we then enabled by:

systemctl enable --now php-fpm

From that point we left the /etc/httpd/conf.d/php.conf as default and restarted httpd

service httpd restart

Then everything worked.

Hope this helps, took way longer than it should have to figure out.

Solution 20

I had the same problem, caused by the Debian/ Ubuntu default configuration of module suphp. It contained suPHP_Engine off for whole /usr/share, which resulted in the php sources being shown in the browser. Deactivating with a2dismod suphp was the interim solution.

Solution 21

I had the same problem. When I run a php file, the web browser showed me the php code instead of execute it. I had tried many times: uninstall/reinstall the wampserver64, working around the PHP/Apache settings/modules, etc. After 2 days: I realised that when I tried to run the php file within the notepad++ by pressing the default combination "ctrl + alt + shift + R" for chrome. It was trying to execute my php file like: "file///C:/wamp64/www/bla/bla.." in my chrome's address bar. That was my problem. I made the changes according to page Configuring Notepad++ to run php on localhost?. My problem was solved. But after 2 days..

Solution 22

Run Xampp (apache) as administrator. In google chrome type:

localhost/<insert folder name here>/<insert file name>

i.e. if folder you created is "LearnPhp", file is "chapter1.php" then type

localhost/LearnPhp/chapter1.php

I created this folder in the xampp folder in the htdocs folder which gets created when you download xampp.

Solution 23

Debian 9 solution:

touch /etc/apache2/conf-available/php.conf 

Add to file next lines:

<IfModule mod_php5.c>
    <IfModule mod_mime.c>
        AddType application/x-httpd-php .php
    </IfModule>
    <FilesMatch ".+\.php$">
        SetHandler application/x-httpd-php
    </FilesMatch>
</IfModule>
<IfModule mod_php.c>
    <IfModule mod_mime.c>
        AddType application/x-httpd-php .php
    </IfModule>
    <FilesMatch ".+\.php$">
        SetHandler application/x-httpd-php
    </FilesMatch>
</IfModule>

Then run:

a2enconf php && service apache2 restart

Solution 24

Some times if you have php version conflicts it happens To overcome that please follow the below steps

Step 1 : Yum list installed | grep 'php'

if you have multiple versions of php like php 5.6 and php 7.0 this confilict will happens

Step 2 : yum remove **your php version **

Step 3 : Then restart the apapche /etc/init.d/httpd restart or service apache2 restart

Solution 25

This solution worked for me. I purged apache2 and reinstall. It happened after purge and install. If it is the first install, you would not face this problem.

Solution 26

In my case with PHP7.3 Apache2.4 Ubuntu 18.04 I had to execute:

$ a2enmod actions fastcgi alias proxy_fcgi

Solution 27

Centos 7, PHP 8, Apache 2

I've recently upgraded a centos server to use php 8.

After the upgrade php had stopped working and apache started serving me the php code as text.

Having spent a good while looking for which config setting had not updated I tracked it down to this:

in /etc/httpd/conf.d

<IfModule  mod_php7.c>

needed changing to:

<IfModule  mod_php.c>

There are other places that you may see the mod_php7 check that could probably be updated to the mod_php variant but this one definitely fixed it for me.

Don't forget to restart the server afterwards.