I'm using Android Studio 0.2.3 and when opened an activity layout normally, the preview should appear on the right side, so that I can switch between Text and Design mode, which should again show the preview of the layout.

But no preview is shown not on the right side neither when I'm in text mode nor in the design mode. I just get the error rendering problems...

When I compile everything and install the app on my device, it works without any errors. For developing and experimenting with the layout, it would still be nice if I could get the preview to work.

I have also tried to switch between different devices in the studio, but no success.

Does anyone know how solve this?

Solution 1

Change your android version on your designer preview into your current version depend on your Manifest. rendering problem caused your designer preview used higher API level than your current android API level.

Adjust with your current API Level. If the API level isn't in the list, you'll need to install it via the SDK Manager.

Solution 2

In new update android studio 2.2 facing rendering issue then follow this steps.

I fixed it - in styles.xml file I changed




It's some kind of hack I came across a long time ago to solve similar rendering problems in previous Android Studio versions.

Solution 3

  1. Open AndroidManifest.xml
  2. Change:


    to something like:

  3. Hit "refresh" button in the "Previev" tab.

Solution 4

I was able to fix this in Android Studio 0.2.0 by changing API from API 18: Android 4.3 to API 17: Android 4.2.2

This is under the Android icon menu in the top right of the design window.

This was a solution from required a Google translation into English since it was in another language.

Hope it helps.

Solution 5

In the Latest Android Studio 3.1.3, Dependency:

implementation ''


Even in latest by 27th of Aug 18 ie

implementation '' facing similar issue

Change it to

    implementation '

This will solve your problem of Preview.


Still, in beta01 there is a preview problem for latest appcompact v7 library make the above change as changing it to alpha01 for solving rendering problem

Solution 6

When I set that android:autofillHints="" /> in .xml file, I met the issue, Android Studio rendering problems, so I set that android:autofillHints="testHint" />, this issue is gone.

Solution 7

I have solved the Problem by changing style.xml

<style name="AppTheme" parent="Base.Theme.AppCompat.Light.DarkActionBar">
     <!-- Customize your theme here. -->

this was an awesom solution.

Solution 8

it still happens in Android Studio 1.5.1. on Ubuntu and you can solve it simply changing a setting from Gradle:

1) on app/build.gradle dependencies change from:

compile ''


compile ''

2) rebuild project

3) refresh view

Best regards,


Solution 9

I had the same problem, current update, but rendering failed because I need to update.

Try changing the update version you are on. The default is Stable, but there are 3 more options, Canary being the newest and potentially least stable. I chose to check for updates from the Dev Channel, which is a little more stable than Canary build. It fixed the problem and seems to work fine.

To change the version, Check for Updates, then click the Updates link on the popup that says you already have the latest version.

Solution 10

In build.gradle below dependencies add:

configurations.all {
    resolutionStrategy.eachDependency { DependencyResolveDetails details ->
        def requested = details.requested
        if ( == "") {
            if (!"multidex")) {
                details.useVersion "27.+"

This worked for me, I found it on stack, addressed as the "Theme Error solution": Theme Error - how to fix?

Solution 11

Rendering didn't work for me too. I had <null> value on the right side of the android icon. I ran

sudo apt-get install gradle

I restarted Android studio then and <null> value changed to 23.

Voila, it renders now! :)

Solution 12

Just download minimum prefered SDK from SDK Manager, then build. Works for me.

Solution 13

Make sure your designer version and targetSdkVersion both is same. Example : If your targetSdkVersion is 22 then change your designer version also 22, so this problem do not occur.

Solution 14

Best Solution is go to File -> Sync Project With Gradle Files

I hope this helped

Solution 15

All you had to do is go to styles.xml file and replace your parent theme from


Solution 16

Open your activity_main.xml . Switch to Design view if you are in text view. Look for the android version,with the android robo icon. Change the android version. Problem solved.

Solution 17

this issue is probably derived from the connection of the laptop to software products like AnyConnect. Killing the remote connection works for me.