android

android-studio

adb

device

avd

The AVD Manager in Android Studio doesn't show my device but adb devices does show it. Am I missing something obvious here?

Solution 1

I recently had trouble with this, and regardless of what I did(restart adb, edit adb_usb.ini, restart computer+device+swap usb port, reinstall studio etc. etc.) I just couldnt get it to work, and could not even detect my device using 'adb devices'. Finally after about 2 hours of googling and testing, someone suggested switching to PTP instead of MTP on my device. When I did this I got a popup on my device asking me to allow my mac access and suddenly everything worked(had to restart studio for it to show up there as well though).

I might be bumping this thread now, but it is the first result on google search, and I had a lot of trouble finding an answer for this problem, so I thought this should be added as a solution.

Solution 2

On your device:

Go to settings/ developer settings/ allow USB debug mode

If 'allow USB debug mode' option is disabled. Then you might have the device currently connected to your PC. Disconnect the device and the option should now be available

Note: On Android 4.2 and newer, Developer options is hidden by default. To make it available, go to Settings > About phone and tap Build number seven times. Return to the previous screen to find Developer options.

If it still doesn't help, you can google it with this expression:

How to enable developer options on YOUR_PHONE_TYPE

Just in case it saves anyone 5 minutes of head-scratching, 'Developer options' is now under 'Settings/System & updates/Developer options'

Solution 3

To change what your application defaults to when you click run or debug in Android Studio, follow these steps:

1. go to Run

2. Click on Edit Configurations

3. Select the project

4. find the Target Device section under the General tab on the Android Application page.

That seems to be where you toggle what the project builds to. If you're importing a project it actually defaults to Emulator, not sure why. You can also select "Open Select Deployment Target Dialog" to list both connected as well as emulated devices.

Solution 4

Some cables can not been used for developer mode or transfer file. A solution would be change your cable and don't waste time.

Trendblog post

Edited

Some USB3 ports are causing issues too. Not sure if there is a way to check if the cable/usb works. But there is a way to detect the USB type USB2 or USB3? . If you are using USB3 could be a port issue too.

Solution 5

I had to killall adb because somehow, Android Studio managed to crash and did not want to communicate with adb anymore. Thus, my device did not show up.

So quitting Android Studio, terminating all adb instances in Terminal and starting Android Studio again (should ask if it should enable debugging then) worked.

Solution 6

After spending some time I found the problem was to enable USB debugging option to on. Just find in your mobile Settings->Developer Option->USB debugging. Just enable it and it works. It might help someone!

Solution 7

It works for me by following steps below:-

If you using Windows, the device won't show up because of driver issue.

Go to device manager (just search it using Start) and look for any devices showing an error. Many androids will show as an unknown USB device and comes with exclamation mark. Select that device and try to update the drivers for it. for update part follow the link:universal adb

But before that, you have to update your sdk manager and make sure Google USB Driver package is installed.

When done, the driver files are downloaded into the \extras\google\usb_driver\ directory. Hints: Search "android_winusb.inf" under Windows Start and Open File Location to get the directory mentioned.

Open up your device manager, navigate to your android device, right click on it and select Update Driver Software then select Browse driver software. Follow the file location path previously to install Google USB Driver.

Restart Android Studio and Developer Options in your android device and reconnect USB.

Cheers !

Solution 8

In my case the following steps helped to resolve the issue:

1) Ensure the package "Google USB Driver" is installed in Android SDK Manager

2) Download "ADB Driver Installer 2.0" from here

3) Run the tool downloaded and connect your smartphone; in my case it showed that the driver had been installed incorrectly and suggested to fix it

After those steps my Android Studio instantly recognised the device! Both MTP and PTP started to work.


Tested for Samsung (Android 4.1.2) and Xiaomi MI4W (Android 4.4.4)

Solution 9

My Nexus 5 phone did not have developer options in the settings menu. I had to do the following:

On Android 4.2 and newer, Developer options is hidden by default. To make it available, go to Settings > About phone and tap Build number seven times. Return to the previous screen to find Developer options.

Solution 10

In my case

android studio suddenly stop seeing my device

I fix it by change USB option to Media device (MTP)

how to get USB option from storage USB Computer Connection

check Debugging from developer options

try re-run on device , it should work

issue

USB option was charge only

UPDATE ANSWER 26/7/2016

there many reasons like not enabling developer mode --> USB debugging(if you dont see developer option click 7 times at build number )

but I face another issue every thing was works just fine suddenly android studio cant see my device

to fix this issue you need to restart adb , from terminal

adb kill-server
adb start-server

or from ddms

in devices section --> click at small arrow down --> restart adb

Solution 11

I plugged my phone in and it was detected fine (no need for device manager or anything like that).. but Android Studio wasn't seeing it.

I found it takes two requirements to be met

- PTP (not MTP)
- USB Debugging mode on

For PTP , go to settings..storage..usb connection..PTP (For MTP/PTP , maybe on my nexus it's there, but on my doogee I see it under 'developer options' .. then under networking , above input, it says "select usb configuration")

For USB debugging, settings..about..tap build about 7 times, then a new option appears for usb debugging and you can turn it on.

Added this is also relevant for USB debugging or MTP/PTP being moved https://android.stackexchange.com/questions/213059/where-is-the-mtp-and-ptp-option-in-android-9

Solution 12

Try the following solutions (for Windows):

  • Go to your sdk tool installation path, and under \sdk\platform-tools folder and run this command:

    adb devices

If your device it listed it should show something like this:

C:\android\sdk\platform-tools>adb devices
List of devices attached
081e96500591f039        device

If not, follow this:

  • Try these commands:

    adb kill-server

    adb start-server

  • Make sure your phone has Developer Options in Settings (if not, go to Settings, About phone (or device), click on Android Version multiple times until you see a message).

  • Make sure USB debugging on your phone is enabled (go to Developer Options in Settings and turn it on)

  • Make sure you have Select USB Configuration set to MTP (this is also in Developer Options).

  • Make sure you can see your files in your device in Windows Explorer when you connect via USB.

  • Make sure you have the driver for your device properly installed (most of the time, this happens when you first plug in your USB cable).

  • In Windows, right click on Computer, and go to Device Manager, check if you have Android Device right on the root folder and under it should be Android Composite ADB Interface. If you don't have this, you have to download the Google USB Driver. Get it here:

http://developer.android.com/sdk/win-usb.html

  • In Device Manager, find your device (should have yellow Exclamation point), right click, and update driver (open the folder with the driver you just downloaded)

  • If this doesn't work, try restarting Android Studio or plugging your device back in again.

Some cheap devices (some $30 tablets) don't provide the USB drivers to connect in Device Manager, so in this case you are out of luck.

Solution 13

I have found that what works for me is:

  • CD to your sdk platform-tools folder

  • Check if adb sees your device

    ./adb devices
    
  • If it displays 'List of devices attached' and a blank line below, then restart adb as follows:

    ./adb kill-server
    ./adb start-server
    

    then re-run ./adb devices and see if it picks up the device, eg as follows:

    List of devices attached
    015d2bc285601c0a device

Solution 14

UPDATE 2020 Nov 27

One more reason is your cable which might be broken (only charging is available but not debugging). Hence, buy a new one! ^^


Known that "Can't connect a device with Android Studio" is such an annoying issue to newbies, but I'm kind of an old hand at Android for a quite long time. Most of the common methods have been tried:

  • How to turn on developer mode.
  • Forgot to enable USB debugging.
  • Sometimes need to switch USB configuration to Transfer Files.
  • Some subliminal guides on adb commands, which I've never tried, though.
  • Try a new cable. ...

HOWEVER, what works for me is to REVOKE ACCESS again for the computer your device will connect to, namely:

  1. Go to Developer options.
  2. Revoke USB debugging authorization.
  3. Wait a bit for a dialogue to show up and ask your access consent.
  4. Bang, there you go, your device is listed in Android Studio.

Solution 15

If your phone was working previously

Before you do anything complicated, this might be a simple problem. Just unplug and plug back in.

If there are additional issues

You also might want to check that your configuration is set up to launch to your phone.

run --> edit configurations

And make sure that you either default to the USB device or the chooser dialog if you are going to be switching between devices on your emulator as well.

Solution 16

Be sure that you have downloaded the correct API for the version you device is using. After updating your device's Android version or switching to a different device you may not have the correct API downloaded on Android Studio. To do this:

  1. Check your devices Android OS version by going to Settings>About Phone>Android Version

  2. Make sure you have the correct API installed in Android Studio in the SDK Manager

Solution 17

Also try uncheck "Tools" - "Android" - "Enable ADB Integration".

This is work for me after update Windows to 10.

Solution 18

After u turn on debug mode open settings/Developer options Update config same image

Solution 19

In my case, I had to set up my android to enable USB debugging.

https://developer.android.com/studio/run/device#setting-up

Solution 20

This helped me. I followed the instructions on the "Troubleshoot Device Connections" located on the AVD Manager Devices dropdown:

  1. Make sure your Android phone is connected via USB to your computer

  2. Go to your Android phone

  3. Go to Settings > About phone > Software information on your phone

  4. Tap Build number seven times

  5. Developer option is now enabled in your phone

  6. Go to Developer

  7. Turn on or enable USB debugging

  8. Allow computer access to phone

  9. Now click on "Troubleshoot Device Connections"

  10. Click Next until you reach "Restart ADB Server". Click on that and restart

Your device should now show on the AVD Manager dropdown list.

Solution 21

If you still have this problem (later than summer 2015) maybe you should:

  1. Go here: http://developer.android.com/sdk/win-usb.html#top
  2. Download the driver
  3. Reinstall it

I recently installed Windows 10 (not an upgrade, a clean installation) and I forgot the ADB USB driver

Solution 22

Try changing mode of usb connection to midi devices. Thats what worked for me.

Solution 23

if your device version in 9 then

Go to SDK Tools and Update Sdk same Version and Intstall Google USB Driver

Solution 24

while doing all this don't forget to increase the sleep time, so that if the device prompts for authentication on the mobile device you know that the connection is succeeded.

Try 1:

  1. Install "microsoft universal c runtime".
  2. Download the file as per your OS (operating system.)
    https://support.microsoft.com/en-in/help/2999226/update-for-universal-c-runtime-in-windows

Installing Google USB Driver from Developersdeveloper.android.com didn't work for me.

Try 2:

  1. search "androidmtk" and install driver installer. (restart pc) (check whether device is showing)
  2. Else search "adbdriver" and install driver installer. (restart pc) (check whether device is showing)

Try 3:

  • Check out whether in Android studio's status bar (displayed at the very bottom of window), any message has been shown. Do the changes suggested in the message.

Try 4:

  • Check whether device is shown after changing the connection type (mostly shown on dragging the top bar on home screen).
  • i.e. "Charging only", "Transfer files", "Transfer photos PTP or MTP"

Try 5:

  • Go to Android "Tools menu"->"SDK manager"->
  • Below "Android SDK location" you will see 3 tabs.
  • Out of it click on "SDK tools" and in the list find and tick-mark "Google USB drivers" and install the package.
  • Restart the computer.

Solution 25

The AVD Manager is for emulator images. It never shows hardware. This is true for any usage of the AVD Manager: Eclipse, Android Studio, etc.

Solution 26

I know it sounds crazy but i just reboot my phone while was connected and it appears

Solution 27

When I faced this problem I was on Android Studio 3.1 version. I tried a lot of approach above, nothing worked for me ( Don't know why :/ ). Finally I tried something different by my own. My approach was:

Before going to bellow steps make sure

*Your "Google USB Driver" package is installed ("Tools" -> "SDK Manager" -> Check "Google USB Driver" -> "Apply" -> "Ok").

*If you are trying to access with emulator then check "Intel x86 Emulator Accelarator(HAXM installer)" is instaled. ("Tools" -> "SDK Manager" -> Check "Intel x86 Emulator Accelarator(HAXM installer)"" -> "Apply" -> "Ok")
  1. Goto Tools.
  2. Then goto SDK Manager.
  3. Open SDK tools.
  4. Uncheck "Android SDK Platform-Tools" (On my case it was checked).
  5. press apply then ok.
  6. Again goto Tools.
  7. Then goto SDK Manager.
  8. Open SDK tools.
  9. check "Android SDK Platform-Tools"
  10. Restart Android Studio :)

Hope this will help somebody like me.

Solution 28

If you use Samsung you can download and install the device driver from Samsung.

Note

  1. You need to enable ADB mode(Like the eleventh comment)

  2. You need to set Target in Android Studio to "Open Select Deployment Target" Dialog. To set Target : Run > Edit Configurations > Targets > Open Select Deployment Target Dialog

Solution 29

Turn on USB debugging and connect the device to PC. Wait until the device gets detected by PC. While connected, turn off USB debugging and turn on it again.

Solution 30

I am using Android Studio 4.0, Android Studio said "Device was detected by ADB but not Android Studio". I tried re-enable "developer option" and "usb debug", re-plugin the usb, but no luck. I restart the Android Studio and it works.

Please try restart the Android Studio.

Hope it could save you some time.