I've just refactored an app into a framework library and an application, but now when I try and start the app in the emulator I get the following error stack trace:

06-02 18:22:35.529: E/AndroidRuntime(586): FATAL EXCEPTION: main
06-02 18:22:35.529: E/AndroidRuntime(586): java.lang.RuntimeException: Unable to instantiate activity ComponentInfo{com.matthewrathbone.eastersays/com.matthewrathbone.eastersays.EasterSimonSaysActivity}: java.lang.ClassNotFoundException: com.matthewrathbone.eastersays.EasterSimonSaysActivity in loader dalvik.system.PathClassLoader[/data/app/com.matthewrathbone.eastersays-1.apk]
06-02 18:22:35.529: E/AndroidRuntime(586):  at
06-02 18:22:35.529: E/AndroidRuntime(586):  at
06-02 18:22:35.529: E/AndroidRuntime(586):  at$2300(
06-02 18:22:35.529: E/AndroidRuntime(586):  at$H.handleMessage(
06-02 18:22:35.529: E/AndroidRuntime(586):  at android.os.Handler.dispatchMessage(
06-02 18:22:35.529: E/AndroidRuntime(586):  at android.os.Looper.loop(
06-02 18:22:35.529: E/AndroidRuntime(586):  at
06-02 18:22:35.529: E/AndroidRuntime(586):  at java.lang.reflect.Method.invokeNative(Native Method)
06-02 18:22:35.529: E/AndroidRuntime(586):  at java.lang.reflect.Method.invoke(
06-02 18:22:35.529: E/AndroidRuntime(586):  at$
06-02 18:22:35.529: E/AndroidRuntime(586):  at
06-02 18:22:35.529: E/AndroidRuntime(586):  at dalvik.system.NativeStart.main(Native Method)
06-02 18:22:35.529: E/AndroidRuntime(586): Caused by: java.lang.ClassNotFoundException: com.matthewrathbone.eastersays.EasterSimonSaysActivity in loader dalvik.system.PathClassLoader[/data/app/com.matthewrathbone.eastersays-1.apk]
06-02 18:22:35.529: E/AndroidRuntime(586):  at dalvik.system.PathClassLoader.findClass(
06-02 18:22:35.529: E/AndroidRuntime(586):  at java.lang.ClassLoader.loadClass(
06-02 18:22:35.529: E/AndroidRuntime(586):  at java.lang.ClassLoader.loadClass(
06-02 18:22:35.529: E/AndroidRuntime(586):  at
06-02 18:22:35.529: E/AndroidRuntime(586):  at
06-02 18:22:35.529: E/AndroidRuntime(586):  ... 11 more

Usually this means that the manifest file is wrong in some way, but I've double checked everything I can think of.

Here is my activity class:

package com.matthewrathbone.eastersays;

import android.os.Bundle;

import com.rathboma.simonsays.Assets.Season;
import com.rathboma.simonsays.SeasonPicker;
import com.rathboma.simonsays.SimonSaysActivity;

    public class EasterSimonSaysActivity extends SimonSaysActivity {

      protected void onCreate(Bundle savedInstanceState) {

      protected void onDestroy() {
        // TODO Auto-generated method stub

      public SeasonPicker getSeasonPicker() {
       return new SeasonPicker(){
        public Season getSeason() {
          // TODO Auto-generated method stub
          return Season.EASTER;

As you can see, it's listed correctly in the manifest:

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android=""
    android:versionName="1.0" >

    <uses-sdk android:minSdkVersion="7" android:targetSdkVersion="15" />

        android:label="@string/app_name" >
            android:label="@string/app_name" >
                <action android:name="android.intent.action.MAIN" />

                <category android:name="android.intent.category.LAUNCHER" />


I have no idea how to fix this, and would appreciate any help. I've scanned many similar questions on SO without seeing this particular behavior.

More info:

  • I've checked inside the generated APK and the class has an entry in the classes.dex file
  • I've tried cleaning/building the project in eclipse
  • I've tried using a totally new device image that doesn't have a copy of the APK on it already
  • I've changed the library project into a regular java, then changed back into an android project, no difference
  • Adding the abstract SimonSaysActivity to the manifest makes no difference.
  • I've tried making every dependency an android library project, and syncing the android version that they require, it did not help

Found the solution (see below). To everyone that posted an answer / comment: You all rock, thanks for helping me work through the problems!

Looks like this is introduced by an SDK tools upgrade. Thanks to @Nick below in the comments for this link:

Solution 1

I spent some time play with my own project, and I am able to replicate your problem and get exactly the same exception stack trace when trying to run my main project, so I think this could be the cause:

Just like what I thought, it is all about how you reference your Android library project in the Android main project, a simple Eclipse configuration settings.

The Wrong Way:
Right click main project, choose Properties -> Java Build Path -> Projects -> Add..., this add the Android library Project as a dependency project in Android main project's build path, this does not work. If all required Android-related resources are defined in main project, you will not get any error at compile time, but when run the application, you get the exception described in the question.

The Correct Way:
Right click main project, choose Properties -> Android, in the Library section, add your Android library project here. Check out official dev guide Referencing a library project. This should fix all your problem. Also note that you have to use relative path reference the actual Android library project, as stated in the Library Project - Development considerations.

Hope this helps.

Solution 2

i've tested the code that you've given , and it works fine. try changing the "extends SimonSaysActivity " to simply "extends Activity " and see for yourself that it works .

the reason that it doesn't work is either SimonSaysActivity doesn't extend Activity (which i don't think you've made this mistake) , or the order of the build path is wrong .

to go to the order of the build path , go to :

project->properties->Java build path->order and export .

my basic order is : project src , project gen , android 4.0.3 , android dependencies .

this problem usually occurs when you use libraries .

Solution 3

I've just refactored an app into a framework library and an application.

I'm not entirely sure what you are trying to say here, but the fact that you used the word "refactored" here leads me to believe that you are misunderstanding the concept of a library project.

What library projects are:

A library project is a development project that contains shared source code and resources. Other Android projects can reference the library project and include its compiled sources in their .apk files at compile time.

What library projects are not:

A library project differs from a standard Android project in that you cannot compile it directly to a single .apk file and run it on an Android device. You can't use an Android projects as a library project, and then have another Android project extend the library project. It doesn't work that way.

That said, I would investigate the structure of your library project and insure that you've set it up correctly. It's OK to use your library to store shared code/resources, but if your library is attempting to behave as if it were a separate .apk within the library project itself, then you've probably done something wrong. I believe a ClassNotFoundException would be thrown if this were the case. To fix the problem, I'd just build the library project from scratch, rather than attempting to convert the Android project to a library project. That'll prevent you from running into tiny, annoying bugs.

Feel free to post more code if you are still having trouble. You should also elaborate a bit more on the structure (and purpose) of your library project... why you decided to use one, how you created it, etc.

Solution 4

For Eclipse Kepler(Mac): Control-click project -> Android Tools -> add support library

Solution 5

I had this problem with a project I was working on, though my case was different. If anyone out there still can't find the solution to their problem, try checking this:

In Eclipse:

Project properties -> Java Build Path -> Source tab

Inside you'll find a list with all the source folders to be compiled and put into the generated apk each time to build your project (and /gen). Tipically:


What you'll want to be sure of is that inside each of your source folders (exclude /gen, so only /src in this case) the item Output folder is poiting to the default output folder, which is MyProject/bin/classes. Do this by selecting Output folder and clicking Remove from the right set of buttons (this will make it point to the default folder).

If you can't see the subitem Output folder, check "Allow output folders for source folders" right below the list

Solution 6

If you followed all the hints (checked the private Libraries etc.) and still have the bug. Check your manifest for this Line of code in the application-tag


Remove it and be happy. (I was finally) :)

Solution 7

classNotFoundException in Java is a subclass of java.lang.Exception and Comes when Java Virtual Machine tries to load a particular class and doesn't found the requested class in classpath.

Read more:

Try going to Project -> Properties -> Java Build Path -> Order & Export And Confirm Android Private Libraries are checked for your project and for all other library projects you are using in your Application.

How to deal with the ClassNotFoundException

  1. Verify that the name of the requested class is correct and that the appropriate .jar file exists in your classpath. If not, you must explicitly add it to your applications classpath.
  2. In case the specified .jar file exists in your classpath then, your applications classpath is getting overriden and you must find the exact classpath used by your application.
  3. In case the exception is caused by a third party class, you must identify the class that throws the exception and then, add the missing .jar files in your classpath.

Solution 8

While this won't be applicable for everyone, I recently had this problem because my project was failing to link with a shared library present on the device. I had forgotten to specify in my manifest that my application <uses-library>.

Solution 9

remove classes.dex from bin and rebuild project

Solution 10

What interfaces or parent classes does SimonSaysActivity use/extend and are they available on the version of Android you're using? I've seen similar problems where my activity implemented an API interface that wasn't available on the version of Android I was using.

In my case my activity implemented the interface PopupMenu.OnDismissListener which is only available in API 14 but when I ran the app on my 2.3 device I received a java.lang.NoClassDefFoundError exception for the activity.

Solution 11

I had the same problem and wasted most of a day trying all sorts of things. The app ran find when deployed from one pc but not on this one pc. In the end it ended up being a missing java nature! Strange how it showed me java build paths, order/export and all that but yet didn't have a java nature. :( Hope this saves someone else a lot of time

Solution 12

solution provided by @yorkw is absolutely correct. I had an additional issue, in one of the layout files, I had mentioned the absolute name incorrectly. It should have been

< xmlns:android="...

rather I had put it

< xmlns:android="...

after resolving these, it worked good.

Solution 13

Believe it or not, the fix for me was to remove the old version (2.0) of google analytics library from my project, after trying everything for at least 4 hours. Of course, an update of this library could be the solution also. So it could be a dependency jar versioning problem.

Solution 14

I was getting these type of error and i have tried everything but didn't get the solution. then i figured out if you are using library as aar file then you have to add all dependencies of your aar library to your app file. if someone didn't figure out solution then try this!

Solution 15

I was getting the same issue. But then i checked the current structure of the application.I found that older application structure(i don't know the time it is changed by android framework developers) has a folder name "lib" which is now "libs". I migrate my all jar files into "libs" and the error is gone. I hope this may help to someone :)