Doing Android development on a Mac and this very new phone I have doesn't show up in the devices list in adb. Lots of other phones and devices work fine for me so I know my setup is good.

I have debugging enabled (Settings --> Applications --> Development --> USB debugging) on the phone, but it just doesn't show up when I run adb devices

Solution 1

Important Update : As @equiman points out, there are some USB cables that are for charging only and do not transmit data. Sometimes just swapping cables will help.

Update for some versions of adb, ~/.android/adb_usb.ini has to be removed.

Executive summary: Add the Vendor ID to ~/.android/adb_usb.ini and restart adb

Full Details: Most of the time nothing will need to be done to get the Mac to recognize the phone/device. Seriously, 99% of the time "it just works."

That being said, the quickest way to reset adb is to restart it with the following commands in sequence:

  adb kill-server
  adb devices

But every now and then the adb devices command just fails to find your device. Maybe if you're working with some experimental or prototype or out-of-the-ordinary device, maybe it's just unknown and won't show up.

You can help adb to find your device by telling it about your device's "Vendor ID," essentially providing it with a hint. This can be done by putting the hex Vendor ID in the file ~/.android/adb_usb.ini

But first you have to find the Vendor ID value. Fortunately on Mac this is pretty easy. Launch the System Information application. It is located in the /Applications/Utilities/ folder, or you can get to it via the Apple Menu in the top left corner of the screen, select "About this Mac", then click the "More Info..." button. Screen grab here:

Expand the "Hardware" tree, select "USB", then look for your target device. In the above example, my device is named "SomeDevice" (I did that in photoshop to hide the real device manufacturer). Another example would be a Samsung tablet which shows up as "SAMSUNG_Android" (btw, I didn't have to do anything special to make the Samsung tablet work.) Anyway, click your device and the full details will display in the pane below. This is where it lists the Vendor ID. In my example from the screenshot the value is 0x9d17 -- use this value in the next command

echo 0x9d17 >> ~/.android/adb_usb.ini

It's okay if you didn't already have that adb_usb.ini file before this, most of the time it's just not needed for finding your device so it's not unusual for that file to not be present. The above command will create it or append to the bottom of it if it already exists. Now run the commands listed way above to restart adb and you should be good to go.

adb kill-server ; adb devices

* daemon not running. starting it now on port 5037 *
* daemon started successfully *
List of devices attached 
123ABC456DEF001 device

Solution 2

Solution specific to Nexus 4 and Nexus 5 for OS X

Got no device listed in the "List of devices attached" when I ran: adb devices

Fix:

  1. Get the SDK (Latest Version) from developer.android.com
  2. Put developer mode on nexus 4 ( About Phone > Build Number > tap 7 times to enter Dev Mode)
  3. A new menu option will come up in the 'Settings' : { } Developer Options
  4. Make sure you check the following under { } Developer options:
    • USB Debugging : Debug mode when USB is connected (Accept the RSA fingerprint popup)
    • Verify apps over USB : Check apps installed via ADB/ADT for Harmful behavior

Try listing your device from ./adb devices and it should work.

Answer taken from: Any idea why adb does not recognize my nexus 4 on mac

Solution 3

If you have installed the application EasyTether, this can interfere with ADB.

From this page you can execute the command:

sudo kextunload /System/Library/Extensions/EasyTetherUSBEthernet.kext 

this will unload your EasyTether extension.

If you need to re-enable EasyTether for tethering, I believe you can use:

sudo kextload /System/Library/Extensions/EasyTetherUSBEthernet.kext 

This worked on my Samsung Galaxy S2. It's been necessary in my case to execute the kextunload command everytime I reboot.

Solution 4

If you are using following devices:
Samsung S3 GT-I9305 (Android 4.1.2)
Mac OS 10.6.8

Do following:

# echo "0x04e8" >> ~/.android/adb_usb.ini
# adb kill-server
# adb devices

(if you are not using Samsung device, change the Vendor ID "0x04e8" to the correct value of your Vendor)

If still not working, you may want to try following:

(1) On your Samsung device, disable "USB Debugging" and re-enable it again
(and try the adb commands again)

(2) Disconnect the USB cable, and re-connect it again

(3) Uninstall Samsung Kies

(4) Install Android File Transfer

(5) Reboot your Mac and the Samsung device

(6) Use hardware device to test your Android app

After getting the devices connected but you suddenly unplug the USB cable, and suppose now "adb devices" cannot see your device any more, even after "adb kill-server", in this case, you may want to try the following:

(1) power off your Mac
(2) disable "USB debuggine" on your Samsung device
(3) power off your Samsung device
(4) power on your Mac
(5) power on your Samsung device
(6) enable "USB debuggine" on your Samsung device
(7) connect the USB cable
(8) Run "adb devices"
(9) You should see the attached device now

Solution 5

Believe it or not, swapping USB cables solved this for me. I'd been using a random one (which wasn't working), and as soon as I switched over to one that came with an actual Android device, it worked.

Another sign that the good cable was working, was that the Android File Transfer app immediately launched, which wasn't happening with the crappy cable.

Solution 6

I had a similar issue. I've discovered that MTP is not supported in OSX. I changed it to PTP, I was promoted to approve my laptop and then my device was finally listed (LG G3).

Solution 7

Also make sure you are not using an USB cable designated for charging only. This just got me. And it actually was labelled "for charging only"

Solution 8

In my case, it was because the USB cable.

I discovered there are two types of USB cables:

  • Those that only supply power
  • Those that supply power and can transfer data

And it's hard to know what type is a USB cable. Now I make a notch on my cables with data transfer.

Solution 9

This only worked for me after I've enabled developer usb debugging on the phone:

On your android phone, go to Settings > About, then tap repeatedly on Build Number until Developer Options is enabled.

Solution 10

NOTE TO FOLKS WHO CANT GET ANY OF THIS ADVICE TO WORK

Try launching Console.app and watching for errors when you plug in your device. I was getting

# The IOUSBFamily is having trouble enumerating a USB device that has been plugged in. It will keep retrying.

It persisted after reboots, so I eventually reset my PRAM and that got it working again.

HOW TO PERFORM A PRAM RESET

  1. Shut your machine down completely.
  2. Briefly hit the power button
  3. Hold down Command + Option + P + R
  4. Wait until you hear the boot chime for a 3rd time
  5. Release all keys and let the machine continue to boot completely

Solution 11

Here is another thing to try, if like me you have tried all of the other answers and have had no luck.

In my case (Android 4.3) I went into the USB settings under the notifications and changed from MTP mode (Media device) to PTP (camera) and as soon as it switched, the device showed up in the ADT device list.

Solution 12

Simply changing the cable and Authorizing the Mac worked for me!

Solution 13

With the newer adb version, you have to remove ~/.android/adb_usb.ini

Solution 14

I was experiencing the same issue and the following fixed it.

  • Make sure your phone has USB Debugging enabled.
  • Install Android File Transfer
  • You will receive two notifications on your phone to allow the connected computer to have access and another to allow access to the media on your device. Enable both.
  • Your phone will now be recognized if you type 'adb devices' in the terminal.

Solution 15

I had to enable USB debugging (Security settings) developer option in addition to USB debugging in Redmi Note 4.

Solution 16

if you are trying to detect a samsung galaxy s3, then on the phone go to settings -> developer options -> make sure usb debugging is checked

Solution 17

Just in case it helps somebody in the future, I had accidentally turned off "USB debugging" in my settings when I was enabling/disabling "Show layout boundaries". So, first check this setting in your "Developer options".

Solution 18

I switched to a different USB port and that got it to show up in the adb devices list.

That was the only thing that worked for me of all the solutions proposed here. It was proposed by @user908643 in this comment.

Solution 19

Another tricky thing with modern Android is you set the device behavior by selecting "Use for" of the device.

If it is set as "Use for" charging for example the device won't be detected by ADB. switching to PTP/MTP other behavior which is more 'active' will auto-magically make your device detectable.

Solution 20

None of the above answers worked for me. On macOS Mojave, open console app, you may see an error like this:

001076.240057 [email protected](null): IOUSBUserClientLegacy::start: missing entitlement com.apple.appledfr.client

Even resetting the mac PFRAM didn't help. To fix this issue:

  1. Connect Android device via USB cable(double USB-C cable worked for me).

  2. Go to Settings -> .. -> Developer Options and click Revoke USB debugging authorizations

  3. The Android phone will go for a reboot.

  4. Go to Settings -> .. -> Developer Options and make sure USB debugging is enabled.

  5. Now in macOS terminal enter:

    adb devices
    
  6. You can see your device listed.

It worked for my Google Pixel 2 phone.

Solution 21

Also make sure you check the vendors website for their "USB" drivers. I had this problem with my AT&T Galaxy Note (Running Android 2.3.6) and it wasn't being recognized by the adb without a driver install that I got from the samsung website.

Solution 22

Try rebooting (if it was ever detected before and stopped showing up) - the mother of all solutions!

Solution 23

None of the tips above worked for me on my Mac OS X Lion set up. I have Motorola phones running 2.3.6. It turns out that I needed to install drivers for Motorola phones. I found them here.

Solution 24

Its damn strange but just plugging to the USB port located next to Thunderbolt port on my mid-2014 MBP with Retina worked!

The other USB port would simply not recognise the device.

Solution 25

On the LG G3 I was able to get it working by installing ADB via homebrew (Installing ADB on MAC OS X) and then disabling/enabling USB debugging.

Solution 26

Tried all the above, the last piece missing was to enable USB Debugging within Developer Options which was hidden on my 4.4 Galaxy Note 10.1.

See item 5.2 from this link.

Solution 27

I had a devil of a time with this.

I attempted this method but it did not work. I ended up turning OFF USB debugging and the device then requested that install motocast.

It attempted to use the build in installer but it kept crashing past the download. After I downloaded it manually and installed it, I was able to do it.

I am running 10.6.8 and the device is a Xoom 2 running 3.2.2

After that installation, it worked fine.

Solution 28

In case, like me, none of the above worked for you, I figured out a very stupid solution.

I'm using a HTC One X on a 2011 Macbook Pro. I just disabled NFC in Settings > Wireless & Networks > More > NFC and viola! Working normally.

Solution 29

I have seen this problem and tried every solution on stackoverflow and other sites, but nothing help me.

I have restarted adb, switching on developer mode and activating usb debugging, uninstalling samsung kies and even exchanging the usb cables to different ports.

But then I read somewhere that different usb cable use different pins for connecting to the laptop or computer.
So I used different usb cable to connect my samsung phone to mac .. and vowwww it works... for me......

Solution 30

In my case, USB debugging wasn't enabled on my device yet connecting the device to my macbook didn't cause the familiar "Allow USB Debugging" dialog to pop up on the screen.