I try to deploy my Mongo database in Mongolabs, everything works fine, and I create a new database. Please see my connectionstring.

    public DbHelper()

        MongoClientSettings settings = new MongoClientSettings()
            Credentials = new MongoCredential[] { MongoCredential.CreateCredential("dbname", "username", "password") },
            Server = new MongoServerAddress("ds011111.mongolab.com", 11111),
            //ConnectTimeout = new TimeSpan(30000)

        Server = new MongoClient(settings).GetServer();

        DataBase = Server.GetDatabase(DatabaseName);


but when I try to connect the database it's shows error like:

Solution 1

Add "?connect=replicaSet" to the end of your connection string if connecting to MongoLab.

new MongoClient("mongodb://username:[email protected]:11111/db-name?connect=replicaSet")

This JIRA ticket has some details: https://jira.mongodb.org/browse/CSHARP-1160

Basically the default is to connect to a replica set member. But MongoLab's Single-Node settings are actually a single node replica set and this causes us to not trust it. Appending ?connect=replicaSet to your connection string will force the driver to move into replica set mode and all will work.

Found that info here.

Solution 2

I am replacing the connection string method in like below.

new MongoClient("mongodb://username:[email protected]:11111/db-name")

Now it's solved.

Please see the answer from Paul Lemke.

Solution 3

Make sure your current ip address is white-listed in mongo db server. If you change your internet provider new IP needs to be white-listed.

Solution 4

Make Sure your auth db is set correctly.

I ran into this issue when I mentioned only the DB i wanted to connect to , and my auth db was different (other than admin db ).

The db-name in this line is considered as the auth DB .

new MongoClient("mongodb://username:[email protected]:11111/db-name?connect=replicaSet")

Then you can change the selected DB Later

mDb = mClient.GetDatabase(mongoDBName);

Solution 5

Same Error Message but not encountered with a MongoLabs deployment.

I just encountered the same error listed in the title with an Asp.Net Core App. My issue was due to an IOC configuration issue.

In my IOC container, my wrapped MongoClient instance was configured with a dependency transient lifestyle.

Per The MongoDb C# Driver:

It is recommended to store a MongoClient instance in a global place, either as a static variable or in an IoC container with a singleton lifetime.

I promoted the lifestyle of my object to a singleton and it resolved the issue.

I am using:

  • .Net Core 2.0
  • Mongo C# Driver version 2.5
  • Castle Windsor for my IOC version 3.3.0

Please reference the C# Driver Client section: http://mongodb.github.io/mongo-csharp-driver/2.5/reference/driver/connecting/#re-use

Solution 6

Make sure the database username is also case sensitive. I ran into this issue because of case sensitivity of the username.

Solution 7

It's related with MongoDB connection error. Probably you don't have permissions or you didn't specify the allowed IPs in MongoDB. Please check for example in MongoDB Compose if you are able to connect with your MongoDB Atlas. If you won't be able to connect, that means that you have wrong MongoDB connection string.

Solution 8

I had the same issue. I was able to connect to MongoDB Atlas Using MongoDb Compass, but using the same connection string in a C# project I got the error "A timeout occured after 30000ms selecting a server using CompositeServerSelector... ---> System.Net.Internals.SocketExceptionFactory+ExtendedSocketException (61): Connection refused".

In my case the problem was caused by my Internet provider router. Switching the connection to my iPhone's 4G hotspot solved the connection issue.

Solution 9

The port 10255 was blocked by my Internet provider/firewall rules. Opening this port at client side fixed the issue.

Solution 10

In my case, while trying to execute the application with docker compose, I forget the environment variables. The problem was resolved by adding the correct environment variables.

Solution 11

I had this issue and turned out the database server was 2 hours behind. Once I fixed its time, the timeout issue was resolved with it.